Monday, June 03, 2013

EMC Unisphere Service Manager (USM) problems with VMware Fusion

I recently tried to get Unisphere Service Manager (USM) running on my Mac with VMware Fusion and was having a terrible time with it.  I would see the spinning ball logo and it would never completely load.


For the life of me I could not get this thing to load.
I'm running a MacBook Pro 2.7 GHz 10.8.3 - 16 GB memory.
Fusion is loaded with Windows 7 64 bit.
I tried different versions of Java, different versions of USM, nothing changed.
I even loaded new VM's thinking maybe I loaded software that conflicted.  No change.
Loaded 32 bit and 64 bit VM's, same thing.

I gave the USM to my son to load on his MBA with Fusion and it worked!?  After laughing at me and giving me the manual he was nice enough to share his Fusion VM with me.  I loaded the VM and it worked on my machine..  I started working my way backwards to set his VM like mine as close as possible.  I finally found the problem.  The desktop tab on Mirrored Folders was causing the problem for me.  Checked, it won't load.  Unchecked, loads great.  If you try this yourself, the system will force you to log out for the change to take effect.



Select your VM - Settings - Sharing


I went back to my VM and once the Desktop option was unchecked, the system logs out and back in and now I can load USM no problem.

These options are automatically set when loading the VM in seamless mode.  I suppose if I had loaded isolated mode, this would not have been an issue.  Hopefully this helps the next person.

3 comments:

Dennis Joyce said...

Big Help. I was banging my head on the table trying to get this to work! Big Thanks!

Mike Munoz - CCIE 9751 said...

Thanks Dennis. I felt your pain. It drove me nuts!!

Yabulda said...

Exactly the same environment as you - thank you very much, this is exactly what I needed. I've been banging my head on this damn thing all afternoon. EMC hardware - great. EMC software - dear god what a mess.